Fix error compileSdkVersion ‘android-24’ requires JDK 1.8 or later to compile

Fix error compileSdkVersion ‘android-24’ requires JDK 1.8 or later to compile

Question:

I use Android Studio and recently got the error:

Error:Execution failed for task ‘:app:compileDebugJavaWithJavac’. compileSdkVersion ‘android-24’ requires JDK 1.8 or later to compile.

But I have it installed already:

:\Users..>java -version
java version “1.8.0_91” Java(TM) SE Runtime
Environment (build 1.8.0_91-b15) Java HotSpot(TM) 64-Bit Server VM
(build 25.91-b15, mixed mode)

How to fix it?  Thanks !!!

Answers:

In Android Studio open:
File > Project Structure > see if JDK location points to your JDK 1.8 directory.

Advertisements

Posted on Thứ Bảy, 23 Tháng Bảy, 2016, in Android Studio, Fix Error, Lập Trình and tagged , , . Bookmark the permalink. Để lại phản hồi.

💭 Comment:

Mời bạn điền thông tin vào ô dưới đây hoặc kích vào một biểu tượng để đăng nhập:

WordPress.com Logo

Bạn đang bình luận bằng tài khoản WordPress.com Log Out / Thay đổi )

Twitter picture

Bạn đang bình luận bằng tài khoản Twitter Log Out / Thay đổi )

Facebook photo

Bạn đang bình luận bằng tài khoản Facebook Log Out / Thay đổi )

Google+ photo

Bạn đang bình luận bằng tài khoản Google+ Log Out / Thay đổi )

Connecting to %s

%d bloggers like this: